カテゴリー
Windows

覚え書-#19。

The same article in English

 なんでだかすごく疲れているので,やったことのメモだけ。

 うちのサーバ OS は Windows7 HP SP1 (x86)。

  1. PHP 5.5.15 (php-5.5.15-Win32-VC11-x86.zip)
    —> PHP 5.5.16 (php-5.5.16-Win32-VC11-x86.zip)
  2. MariaDB 10.0.12 (mariadb-10.0.12-win32.zip)
    —> MariaDB 10.0.13 (mariadb-10.0.13-win32.zip)
  3. phpMyAdmin 4.2.7 (phpMyAdmin-4.2.7-english.zip)
    —> phpMyAdmin 4.2.7.1 (phpMyAdmin-4.2.7.1-english.zip)

 全部,単なるセキュリティアップデート。なので,速やかに対処。

「覚え書-#19。」への9件の返信

今晩は

今phpのバージョンをあげました。
今度こそこれが最後のphp5.5になるかな?

いずれはhttpがhttpsに向かうでしょうけど、
まだまだ当分先でしょうね。

仰るとおりapache,opensslで対応してないバージョンが多いです。会社でも6台のうち対応してるサーバーが2台のみです。
サーバー側でさえこんな状況ですから、まだまだ先になるとおもいます。

くりくりさん,こんばんは。

> 今度こそこれが最後のphp5.5になるかな?
そうですね。 PHP 5.6.0 GA の予定が, 8 月 28 日ですから,我が家やくりくりさんのところのアップデートは,よほどとんでもない脆弱性が見つかってのありがたくないセキュリティリリースがない限り,そうなるかもしれません。

PHP 5.6.0 RC4 が出たときに Last 5.3 release ever available: PHP 5.3.29 – 5.3 now EOL も出ましたが,これ見ると, PHP 5.4 のサポートが 2015 年, PHP 5.5 のサポートが 2016 年までとなっています。もちろん,まだ EOL の話なしの最低限という記述なので,実際にはもっと先までサポートされる可能性もあるのですが, 5.6 の次は何になるんでしょうか。 5.7 かな, 6.0 かな。

PHP 5.6.0 GA がリリースされたら,多分すぐ入れるんだろうなぁ→自分。

> まだまだ当分先でしょうね。
なんでしょうね。商売も絡む実際のサービスとなると,相当のパーセンテージで環境が追い付いてないと踏み切れませんから。しかし,勉強はしておかないといけないんでしょうネ。ついていけてないことばかりで,困ってしまうなぁ。

こんにちは

>ついていけてないことばかりで,困ってしまうなぁ。
うーん、自分でやっていてあれなんですけど、httpsが多くなってきたらまとめサイトや導入サイトみたいので試すのが一番楽かなとおもいます。

昨日の夜
もうhttpsでやることないだろうなと最終確認していましたら
httpからhttpsに変更した場合、httpには301コードを返すように設定しないといけないらしくconfファイルを変更しました。

設定の確認をとあるサイトでステータスコードチェッカーなるもので自分のサイトを調べていたのですが、httpからhttpはあります。しかし、httpsはありませんでした。

ならlinuxなんだしwgetコマンド使えばわかるだろうと思いためしたらうまく301を返してるのを確認。しかし、証明書のエラーが発生。ブラウザは発生しません。

エラー内容をネットで調べるとバグ見たいことが書いてあるしよくわからない。この時点で夜中の2時。
よく朝思い出したのがo6asanさんにSNIに対応してないというのを思い出してwgetコマンドのバージョンを調べたら対応してませんでした。

もうおなかいっぱいです・・・。

くりくりさん,こんにちは。

> まとめサイトや導入サイトみたいので試すのが一番楽
そうですね。もっとも,改めて考えてみると,今の私の境遇だと,同一 IP 上で複数の証明書を使い分ける必要なんてことへの遭遇自体が,なさそうでもあります(爆)。

> wgetコマンドのバージョンを調べたら対応してませんでした。
あら,そうでしたか。たしかに, 1.14 から対応みたいですね。でも,いろいろとパッチのことが書いてあるので, CentOS6 で安全に使えるものがないのかなと調べてみました。 RHEL6 のなら同じでないですか? wget: Missing support for SNI というのがありましたよ。パッチのあり場所が書いてあります。

おはようございます。

SNIのパッチありがとうございます。
さて、いよいよ明日php5.6。

webtatic.comも対応してくれたらすぐ導入します。
思い白いことにhttpsとhttpだとwebtaticのwordpressが微妙にちがいます。
https://webtatic.com/
http://webtatic.com/
httpsだとphp5.5.16がかいてありますが、
httpだとかいてありません。

くりくりさん,こんばんは。

> さて、いよいよ明日php5.6。
どうせ UTC でしょうから, JST だと 29 日にかかりそうですが,予定通り出ますかね。

https://webtatic.com/http://webtatic.com/ のルート設定なかなか面白いです。今回だけなのかもしれませんが,https://webtatic.com/ では 最新のテストバージョンが, http://webtatic.com/ ではステーブルが表示されるようになってるみたいですね。 https と http のファイルの物理的な場所は同じみたいですが, https だと //webtatic.com/news/2014/08/latest-updates-in-testing-20/ が表示され, http だと //webtatic.com/news/2014/08/latest-updates-php-5-5-15-5-4-31-mysql-5-5-39/ が表示されてます。

この辺,詳しくないのですが, Apache だと .htaccess + Rewirte とかで対処するのでしょう??? webtatic.com は Nginx のようですが,その場合は何を使うのですか。

追記です。

後で気づきましたが,サイドバーの Latest News の項目も違う順になっていますね。 .htaccess + Rewirte とかではなく, WordPress 内で対処させているのでしょうか。

あるいは, https と http のdoc の物理的位置そのものが違うのでしょうか。

おはようございます。

>どうせ UTC でしょうから,
まだでていませんね。

nginxの場合は
http://nginx.org/ja/docs/http/converting_rewrite_rules.html
効率の悪いやり方とかいてあるほうでwwwなしをありに統一と
すべてwwwありのhttpsにしてます。
試してませんけど、wordpress単体でもできそうですね。

>WordPress 内で対処させているのでしょうか。

これはどちらでそうしてるのか正直わかりません。

さてplesk11なんですが、いつのまにかnginxがつかえるようになってました。256のconfエラーでapacheのみの運用をしていたんですけどね。gzipとブラウザキャッシュが使えるよう用に変更の仕方をきいたらnginxとapacheの運用に戻すか考え中です。

しかし、nginxのconf見るとすべてapacheで処理するみたくなってるんで事実上apacheと同じなんですよね。戻しても意味ないしな・・・。

くりくりさん,こんばんは。

> まだでていませんね。
Windows 版は出てましてね (Aug-27 21:52:22=Aug-28 06:52:22JST)。ここのところ(私の記憶だと,前々回くらいからかな), Windows 版のほうがリリースが早いんです。なんででしょうね。

というわけで,アップデートしてみました。18:30ごろに完了。例のプラグインが足を引っ張ってくれて手間取りました。記事はこれから書きまーす。

追記(8/29):
上記はぬれぎぬ。犯人は,php_opcache.dll だった。例のプラグイン君,ごめんなさい。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です